Why is IPv6 Deployment Important for the Internet Evolution?
DOI:
https://doi.org/10.26636/jtit.2011.2.1139Keywords:
Internet evolution, IPv6, migration, mobility, NextGeneration Internet, researchAbstract
Replacing the IPv4 protocol with IPv6 on the Internet is currently one of the aims of the European Union policy. The main reason for this replacement is the effeteness of the addresses pool in the IPv4 protocol, which can cause serious complications in the evolution of the Internet and its adaptation in new areas, e.g., in next generation mobile telephony or the so called Internet of Things. Simultaneously, the addressing capabilities of the IPv6 protocol are practically unlimited and its new functionalities increase the attractiveness of its usage. The article discusses the problems connected with the IPv6 deployment on the Internet. Especially, the rules for realization of the IPv6 deployment and rules for cooperation of IPv4 with IPv6 (including cooperation tests) in network infrastructure and in applications are presented. Moreover, the European projects’ results and the activity’s directions of the national project Future Internet Engineering are discussed.
Downloads
References
[1] S. Deering and R. Hinden, „Internet Protocol, version 6 (IPv6) Specification”, IETF, RFC 2460, http://datatracker.ietf.org/doc/rfc2460/
View in Google Scholar
[2] The tool for forecasting of IPv4 allocation addresses speed in IANA, http://www.potaroo.net/tools/ipv4/fig18.png
View in Google Scholar
[3] F. Watanabe, „A view of cellular network migration toward IPv6” [Online]. Available: http://www.apricot.net/apricot2005/slides/C3-3_1.pdf
View in Google Scholar
[4] P. Grossetete, „Internet of Things - The Case of Environmental (IPv6) Monitoring Applications” [Online]. Available: http://ec.europa.eu/information_society/policy/ipv6/docs/ipv6_meeting_march_2009/patrick_grossetete_en.pdf
View in Google Scholar
[5] R. Droms, „Dynamic Host Configuration Protocol for IPv6”, IETF, RFC 3315, July 2003.
View in Google Scholar
[6] Dibbler project, http://klub.com.pl/dhcpv6/
View in Google Scholar
[7] C. D. Marsan, „YouTube turns on IPv6 support, net traffic spikes”, PCWorld Mag., Feb. 2010.
View in Google Scholar
[8] „MySQL 5.1 Reference Manual”, Section 17.7.2.22, January 2009.
View in Google Scholar
[9] Euro6Ix project, http://www.euro6ix.net/
View in Google Scholar
[10] 6NET project, http://www.6net.org/
View in Google Scholar
[11] 6DISS project, http://www.6diss.org/
View in Google Scholar
[12] 6DEPLOY project, http://www.6deploy.eu/
View in Google Scholar
[13] Moonv6 project, http://www.moonv6.com/
View in Google Scholar
[14] IPv6 forum, IPv6 Ready Logo Program, http://www.ipv6ready.org
View in Google Scholar
[15] TAHI project, http://www.tahi.org
View in Google Scholar
[16] Go4IT project, http://www.go4-it.eu
View in Google Scholar
[17] 6CHOICE project, http://www.6choice.eu/
View in Google Scholar
[18] KAME project, http://www.kame.net/
View in Google Scholar
[19] SixXS project, http://www.sixxs.net/
View in Google Scholar
[20] Polish Task Force IPv6, http://www.pl.ipv6tf.org
View in Google Scholar
[21] K. Nowicki and J. Światowiak, Protokoły IPv6. Opis protokołów, materiały do laboratorium. Gdańsk: Wydawnictwo PG, 2001 (in Polish).
View in Google Scholar
[22] W. Burakowski, „Internet Przyszłości - nowa generacja sieci telekomunikacyjnych”, Telekomunikacja i Techniki Informacyjne, 3-4/2009, pp. 117-126 (in Polish).
View in Google Scholar
[23] J. Ruiz, A. Vallejo, and J. Abella, „IPv6 conformance and interoperability testing”, in Proc. 10th IEEE Symp. Comput. Commun. ISCC 2005, La Manga del Mar Menor, Spain, 2005.
View in Google Scholar
[24] D. Hankins and T. Mrugalski, „Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Options for Dual-Stack Lite”, draft-ietf-softwire-ds-lite-tunnel-option-02, March 2010 [Online]. Available: http://tools.ietf.org/id/draft-ietf-softwire-ds-lite-tunnel-option-04.html
View in Google Scholar
[25] R. Despres, „IPv6 Rapid Deployment on IPv4 Infrastructures (6rd)”, IETF, RFC 5569, January 2010.
View in Google Scholar
Downloads
Submitted
Published
Issue
Section
License
Copyright (c) 2023 Journal of Telecommunications and Information Technology

This work is licensed under a Creative Commons Attribution 4.0 International License.