The IP QoS System

Authors

DOI:

https://doi.org/10.26636/jtit.2011.3.1151

Keywords:

classes of service, DiffServ, multi-service networks, NGN, quality of service

Abstract

This paper shortly describes the IP QoS System which offers strict quality of service (QoS) guarantees in IP-based networks and supports a number of, so called, classes of services. Such solution requires to implement in the network a set of QoS mechanisms and algorithm working on packet, connection request and provisioning levels. Furthermore, we require signaling system for informing the network about new connection request and network resource allocation capabilities for providing required resources to given connection. The IP QoS System is based on the next generation networks (NGN) and differentiated services (DiffServ) architectures and, at least for now, it is designed for single domain only.

Downloads

Download data is not yet available.

References

[1] S. Blake et al., „An Architecture for Differentiated Services”, Internet RFC 2475, December 1998.
View in Google Scholar

[2] D. Grossman, „New Terminology and Clarifications for Diffserv”, Internet RFC 3260, April 2002.
View in Google Scholar

[3] Y. Bernet et al., „An Informal Management Model for Diffserv Routers”, Internet RFC 3290, May 2002.
View in Google Scholar

[4] J. Babiarz, K. Chang, and F. Baker, „Configuration Guidelines for DiffServ Service Classes”, IETF RFC 4594, August 2006.
View in Google Scholar

[5] C. Brandauer et al., „AC algorithms in Aquila QoS IP network”, Eur. Trans. Telecommun., vol. 16, no. 3, pp. 225-232, May-June 2005.
View in Google Scholar

[6] B. F. Koch and H. Hussmann, „Overview of the project AQUILA (IST-1999-10077)”, in Proc. Art-QoS 2003 Workshop, Warsaw, Poland, in Architectures for Quality of Service in the Internet, W. Burakowski, B. F. Koch, and A. Bęben, Eds., LNCS 2698, Springer, 2003, pp. 154-164.
View in Google Scholar

[7] A. Bąk, W. Burakowski, F. Ricciato, S. Salsano, and H. Tarasiuk, „A framework for providing differentiated QoS guarantees in IP-based network”, Comput. Commun., vol. 26, pp. 327-337, 2003.
View in Google Scholar

[8] W. Burakowski and M. Dąbrowski, „Wielousługowa sieć IP QoS: architektura i praktyczna weryfikacja w sieci pilotowej”, Przegląd Telekomunikacyjny, no. 5, pp. 300-309, 2002 (in Polish).
View in Google Scholar

[9] E. Mingozzi et al., „EuQoS: End-to-end quality of service over heterogeneous networks”, Computer Communications, vol. 32, issue 12, Elsevier, July 2009.
View in Google Scholar

[10] X. Masip-Bruin et al., „The EuQoS system: A solution for QoS routing in heterogeneous networks”, IEEE Commun. Mag., vol. 45, no. 2, 2007.
View in Google Scholar

[11] W. Burakowski, A. Bęben, H. Tarasiuk, and J. Śliwiński, „Zapewnienie jakości przekazu „od końca do końca” w sieci Internet: 6.PR IST EuQoS”, Przegląd Telekomunikacyjny, no. 9, pp. 236-241, 2006 (in Polish).
View in Google Scholar

[12] ETSI ES 282 001 V1.1.1, „Telecommunications and Internet converged Services and Protocols for Advanced Networking (TISPAN); NGN Functional Architecture Release 1”.
View in Google Scholar

[13] „Resource and Admission Control Functions in Next Generation Networks”, ITU-T Recommendation Y.2111, 2006.
View in Google Scholar

[14] „Architectural framework for the Q.33xx series of Recommendations”, ITU-T Recommendation Q.3300, 2008.
View in Google Scholar

[15] W. Burakowski et al., „Provision of end-to-end QoS in heterogeneous multi-domain networks”, in Annals of Telecommunications - Annales des Télécommunications, Springer, vol. 63, issue 11, p. 559, 2008.
View in Google Scholar

Downloads

Submitted

2023-06-28

Published

2011-09-30

Issue

Section

RESEARCH ARTICLES

How to Cite

[1]
W. Burakowski, “The IP QoS System”, JTIT, vol. 45, no. 3, pp. 5–11, Sep. 2011, doi: 10.26636/jtit.2011.3.1151.

Most read articles by the same author(s)

1 2 3 4 > >>