Impact of Signaling System Performance on QoE in Next Generation Networks

Authors

DOI:

https://doi.org/10.26636/jtit.2009.4.1005

Keywords:

call setup delay, class of service, heterogeneous networks, next generation networks, quality of experience, qualityof service, signaling system

Abstract

The first experience of quality by multimedia applications’ users takes place during the setup phase of a new connection. If the setup phase is not accepted or "slowly accepted", the confidence of the user decreases. The user becomes more sensitive when he/she pays the connections with assured quality of service (QoS). In this case, the process of call request should be also accomplished with QoS guarantees. This paper presents the signaling sub-system implemented within the EuQoS system. The EuQoS signaling process follows main assumptions of next generation networks (NGN) architecture and performs tasks related with codec agreement between multimedia end users, admission control and resource reservation functions. In this paper, we present analytical, simulation and experimental results showing the impact of signaling system performance on quality of experience (QoE) for the potential users of multi-layer EuQoS system. In particular, the presented approach aims at ensuring user QoE of the connection setup phase by ensuring QoS for transferring signaling messages by the network.

Downloads

Download data is not yet available.

References

[1] „The EuQoS Consortium” [Online]. Available: http://www.euqos.eu/
View in Google Scholar

[2] X. Masip-Bruin et al., „The EuQoS system: a solution for QoS routing in heterogeneous networks”, IEEE Commun. Mag., vol. 45, no. 2, pp. 96-103, 2007.
View in Google Scholar

[3] W. Burakowski et al., „Provision of end-to-end QoS in heterogeneous multi-domain networks”, Ann. Telecommun. Springer, vol. 63, iss. 11, p. 559, 2008.
View in Google Scholar

[4] J. Babiarz and F. Baker, „Configuration Guidelines for DiffServ Service Classes”, RFC 4594, Aug. 2006.
View in Google Scholar

[5] K. Chan, J. Babiarz, and F. Baker, „Aggregation of Diffserv Service Classes”, RFC 5127, Febr. 2008.
View in Google Scholar

[6] „Signaling Requirements for IP QoS”, ITU-T TR Q-Series Supplement 51 (10/2004).
View in Google Scholar

[7] „Resource and admission control functions in next generation networks”, ITU-T Rec. Y.2111 (09/2006).
View in Google Scholar

[8] „General overview of NGN”, ITU-T Rec. Y.2001 (10/2004).
View in Google Scholar

[9] „Framework for the network management of IP-based networks”, ITU-T Rec. E.417 (02/2001).
View in Google Scholar

[10] „Network grade of service parameters and target values for circuit-switched services in the evolving ISDN”, ITU-T Rec. E.721 (05/1999).
View in Google Scholar

[11] „Network post-selection delay in PSTN/ISDN networks using Internet telephony for a portion of the connection”, ITU-T Rec. E.671 (03/2000).
View in Google Scholar

[12] „Network grade of service parameters and target values for maritime and aeronautical mobile services”, ITU-T Rec. E.774 (10/1996).
View in Google Scholar

[13] „Quality of experience requirements for IPTV services”, ITU-T Rec. G.1080 (06/2008).
View in Google Scholar

[14] A. van Moorsel, „Metrics for the Internet age: quality of experience and quality of business”, in Fifth Perform. Worksh., Nuremberg, Germany, 2001.
View in Google Scholar

[15] H. Tarasiuk et al., „Designing the simulative evaluation of an architecture for supporting QoS on a large scale”, in Proc. QoSim 2008 Conf., Marseille, France, 2008 (to appear ACM Digital Library).
View in Google Scholar

[16] CISCO systems document [Online]. Available: http://www.cisco.com/en/US/tech/tk652/tk701/technologies_white_paper09186a00800a9818.shtml.
View in Google Scholar

[17] V. Matic, I. Franicevic, and D. Sekalec, „Parallel SIP proxy servers using direct routing approach”, in Proc. Int. Conf. Softw. Telecommun. Comput. Netw. SoftCOM 2006, Split-Dubrovnik, Croatia, 2006.
View in Google Scholar

[18] „Host Intrusion Detection System (HIDS) v3.1. Sizing Guidelines and Tuning Primer”, HP Company internal document, Sept. 2005.
View in Google Scholar

[19] Y. Bai et al., „A novel distributed wireless VoIP server based on SIP”, in Proc. Multimed. Ubiquit. Eng. Conf. MUE’07, Seoul, Korea, 2007.
View in Google Scholar

[20] A. Beben, „EQ-BGP: an efficient inter-domain QoS routing protocol”, in Proc. 20th IEEE Int. Conf. Adv. Inform. Netw. Appl., Los Alamitos, USA, 2006, pp. 560-564.
View in Google Scholar

[21] N. Morita, H. Imanaka, O. Kamatani, T. Oba, and K. Tanida, „Overview and status of NGN standardization activities at ITU-T”, NTT Tech. Rev., Nov. 2007.
View in Google Scholar

[22] J. Song et al., „Overview of ITU-T NGN QoS control”, IEEE Commun. Mag., vol. 45, no. 9, pp. 116-123, 2007.
View in Google Scholar

[23] P. Calhoun et al., „Diameter Base Protocol”, RFC 3588, Sept. 2003.
View in Google Scholar

[24] R. Hancock et al., „Next Steps in Signaling (NSIS): Framework”, RFC 4080, June 2005.
View in Google Scholar

[25] D. Durham et al., „The COPS (Common Open Policy Service) Protocol”, RFC 2748, Jan. 2000.
View in Google Scholar

[26] J. Mongay Batalla and R. Janowski, „Provisioning dedicated class of service for reliable transfer of signaling traffic”, in Proceedings 20th International Teletraffic Congress, June 2007, Ottawa, Canada, Lecture Notes in Computer Science, vol. 4516. Berlin-Heidelberg: Springer, 2007, pp. 853-864.
View in Google Scholar

[27] P. Rodriguez and E. W. Biersack, „Dynamic parallel access to replicated content in the Internet”, IEEE/ACM Trans. Netw., vol. 10, no. 4, pp. 455-465, 2002.
View in Google Scholar

[28] J. Rosenberg et al., „SIP: Session Initiation Protocol”, RFC 3261, June 2002.
View in Google Scholar

[29] „The Network Simulator ns-2” [Online]. Available: http://www.isi.edu/nsnam/ns/
View in Google Scholar

[30] „The ns-2 signaling modules” [Online]. Available: http://tnt.tele.pw.edu.pl/include/tools/sim-euqos-ptl.tgz
View in Google Scholar

Downloads

Submitted

2023-06-26

Published

2009-12-30

Issue

Section

RESEARCH ARTICLES

How to Cite

[1]
J. M. Batalla, J. Śliwiński, H. Tarasiuk, and W. Burakowski, “Impact of Signaling System Performance on QoE in Next Generation Networks”, JTIT, vol. 38, no. 4, pp. 124–137, Dec. 2009, doi: 10.26636/jtit.2009.4.1005.

Most read articles by the same author(s)

1 2 > >>