Linux Scheduler Improvement for Time Demanding Network Applications, Running on Communication Platform Systems
DOI:
https://doi.org/10.26636/jtit.2009.2.929Keywords:
communication platform systems, Linux, operating system, schedulerAbstract
Communication platform systems as, e.g., advanced telecommunication computing architecture (ATCA) standard blades located in standardized chassis, provides high level communication services between system peripherals. Each ATCA blade brings dedicated functionality to the system but can as well exist as separated host responsible for servicing set of tasks. According to platform philosophy these parts of system can be quite independent against another solutions provided by competitors. Each system design can be different and can face with many computer systems design problems. One of the most difficult design problems to solve is system integration with a set of components running on different operating system levels. This paper presents Linux scheduler improvement possibility to make user space application classified as time demanding (required to be serviced by CPU in given amount of time) running in user space together with complicated kernel software structure in the system.
Downloads
References
[1] ATCA - PICMG 3.0 R2.0: ECN 3.0-2.0-001 [Online]. Available: http://www.picmg.org
View in Google Scholar
[2] ATCA - Intelligent Platform Management Interface Specification Second Generation v2.0, Feb. 2006.
View in Google Scholar
[3] L. Null and J. Lobur, The Essentials of Computer Organization and Architecture. Sudbury: Jones & Bartlett Publ., 2006.
View in Google Scholar
[4] „Security Architecture for the Internet Protocol”, RFC 4301.
View in Google Scholar
[5] „Internet Key Exchange (IKEv2) Protocol”, RFC 4306.
View in Google Scholar
[6] Montavista Linux [Online]. Available: http://www.montavista.com
View in Google Scholar
[7] WindRiver [Online]. Available: http://www.windriver.com
View in Google Scholar
[8] Linux GPL [Online]. Available: http://www.gnu.org
View in Google Scholar
[9] „Virtual Router Redundancy Protocol (VRRP)”, RFC 3768.
View in Google Scholar
[10] „A Simple Network Management Protocol (SNMP)”, RFC 1157.
View in Google Scholar
[11] J. Aas, „Understanding the Linux 2.6.8.1 CPU scheduler”, SGI, 2005.
View in Google Scholar
[12] Linux kernel sources [Online]. Available: http://kernel.org
View in Google Scholar
[13] Linux kernel preemption project [Online]. Available: http://kpreempt.sourceforge.net/
View in Google Scholar
Downloads
Submitted
Published
Issue
Section
License
Copyright (c) 2023 Journal of Telecommunications and Information Technology

This work is licensed under a Creative Commons Attribution 4.0 International License.