Planning the introduction of IPv6 in NATO

Authors

  • Robert Goode NATO C3 Agency (NC3A), The Netherlands

DOI:

https://doi.org/10.26636/jtit.2006.3.381

Keywords:

Internet Protocol, IPv6, transition, NATO, CIS

Abstract

The NATO wide area network provides secure IP services to NATO commands and agencies, and offers information exchange gateways to nations and coalition operations. The IP services support the NATO-wide deployment of core automated information systems (AIS), and the placement of specific functional area services (e.g., intelligence, logistics, C2IS for the services, etc.) at commands. To maintain and improve interoperability within NATO and with partners, NATO will transition from version four of the Internet Protocol (IPv4) to version six (IPv6). The transition to IPv6 will involve the IP network, the information exchange gateways, the core AIS, the functional area services, and the supporting CIS infrastructure. The IPv6 naming and addressing plan being developed supports the NATO command structure and interoperability with NATO partners. The critical issue in the planning process is to support the incremental introduction of IPv6 whilst maintaining network security and reliable interworking with existing IPv4 systems and limiting increases in operations and maintenance costs. To minimise costs and maximise effectiveness NATO is planning the transition in a timescale that is commensurate with commercial adoption in NATO countries, the technology refreshment points for major systems, and the availability of IPv6 security components. New NATO projects will prepare for the transition by detailing their IPv6 upgrade path and procuring dual stack (IPv4 and IPv6) equipment. NATO will develop and adopt standardised approaches for IPv6 protocols and network design.

Downloads

Download data is not yet available.

References

[1] S. Deering and R. Hinden, "Internet Protocol, Version 6 (IPv6) specification", RFC 2460, Dec. 1998.
View in Google Scholar

[2] J. Stenbit, "Memorandum Establishing DoD Policy for Transition to Internet Protocol Version 6 (IPv6)", US Department of Defense, ASD NII-DoD CIO, 9 June 2003.
View in Google Scholar

[3] "IPv6: Federal Agencies need to plan for transition and manage security risks", Rep. GAO-05-471, http://www.gao.gov/new.items/d05471.pdf
View in Google Scholar

[4] "Transition planning for Internet Protocol Version 6 (IPv6)", in Executive Office of the President, Office of Management and Budget as OMB M-05-22 Memorandum for the Chief Information Officers number M-05-22, on Aug., 2005, http://www.whitehouse.gov/omb/memoranda/fy2005/m05-22.pdf
View in Google Scholar

[5] "Next generation Internet - priorities for action in migrating to the new Internet Protocol IPv6", in COM(2002) 96 final by the Commission of the European Communities on 21.02.2002 as a communication from the Commission to the Council and the European parliament, http://europa.eu.int/eur-lex/en/com/cnc/2002/com2002_0096en01.pdf
View in Google Scholar

[6] L. Huang, "Microsoft IPv6 Update", in North Amer. IPv6 Summit, 2005, http://usipv6.unixprogram.com/North_American_IPv6_Summit_2004/052005/tue/Leigh_Huang.pdf
View in Google Scholar

[7] R. Gilligan and E. Nordmark, "Transition mechanisms for IPv6 hosts and routers", RFC 2893, Aug. 2000.
View in Google Scholar

[8] D. Haskin and R. Callon, "Routing aspects of IPv6 transition", RFC 2185, Sept. 1997.
View in Google Scholar

[9] B. Carpenter and K. Moore, "Connection of IPv6 domains via IPv4 clouds without explicit tunnels", RFC 3056, Febr. 2001.
View in Google Scholar

[10] 6bone, http://www.6bone.net/
View in Google Scholar

[11] I. Guardini, P. Fasano, and G. Girardi, "IPv6 operational experience within the 6bone", http://carmen.cselt.it/papers/inet2000/index.htm
View in Google Scholar

[12] J. Dockal and T. Fiala, "Research of the migration from IPv4 to IPv6 in the Czech Army", in Proc. 6th NATO Reg. Conf. Milit. Commun. Inform. Syst., Zegrze, Poland, 2004, pp. 357-362.
View in Google Scholar

[13] T. Chown, "IPv6 campus transition experiences", in Proc. Int. Symp. Appl. Internet SAINT 2005, Trento, Italy, 2005.
View in Google Scholar

[14] M. Brig, "Integration techniques - a technical brief on the methods of transitioning to IPv6", in US IPv6 Summit, Reston, USA, 2004, http://usipv6.unixprogram.com/usipv6_reston_2004/tue/Brig.pdf
View in Google Scholar

[15] V. Pecus, "DoD IPv6 applications transition planning guidelines", in US IPv6 Summit, Reston, USA, 2004, http://usipv6.unixprogram.com/usipv6_reston_2004/thu/Pecus.pdf
View in Google Scholar

[16] R. Goode, P. Guivarch, and M. Stell, "Quality of service in an IP crypto partitioned network", in Proc. MILCOM 2002, Anaheim, USA, 2002, vol. 2, pp. 1154-1159.
View in Google Scholar

[17] P. Sevenich and C. Reichmann, "Multiplexing time-critical and conventional data over tactical IPv6 networks of low bandwidth", in INSC Symp., The Hague, The Netherlands, 2003, http://insc.nodeca.mil.no/ifs/files/public/Symposium/Symposium
View in Google Scholar

[18] M. Amanowicz, P. Sevenich, J. Jarmakiewicz, and M. Pilz, "Quality of service support in IPv6-based military networks with limited bandwidth", in Proc. RTO IST-054 Symp. Milit. Commun., Rome, Italy, 2005.
View in Google Scholar

[19] M. Diepstraten and R. Parker, "NATO AIS cooperative zone technologies", in Proc. 4th NATO Reg. Conf. Milit. Commun. Inform. Syst. RCMCIS, Zegrze, Poland, 2002, pp. 207-216.
View in Google Scholar

[20] S. Cresdee, M. Diepstraten, E. Frambach, W. Hoogeveen, F. Nolden, L. Schenkels, and D. Stanley, "NATO AIS information exchange gateway evolution", in Proc. 5th NATO Reg. Conf. Milit. Commun. Inform. Syst. RCMCIS, Zegrze, Poland, 2003.
View in Google Scholar

[21] "IPv6 ready at URL", http://www.ipv6ready.org/frames.html
View in Google Scholar

[22] "IPv6 standardisation report", IST-2001-34056, M. Ford, Ed., 2005, in European Commission as deliverable D5.1.10 under WP5 as part of the EC Information Society Technologies 6LINK programme; PDF version available via the homepage of the European Commission IST IPv6 cluster, http://www.ist-ipv6.org
View in Google Scholar

[23] D. Coe and A. Sekelsky, "IPv6 capable - DoD definition", in US IPv6 Summit, Reston, USA, 2004, http://usipv6.unixprogram.com/usipv6_reston_2004/thu/Coe-Sekelsky.pdf
View in Google Scholar

[24] "Interoperable networks for secure communications (INSC)", http://insc.nodeca.mil.no/
View in Google Scholar

[25] S. Gee, "Internetworking for coalition interoperability", in 9th Int. Comm. Contr. Res. Technol. Symp., Copenhagen, Denmark, http://www.dodccrp.org/events/2004/ICCRTS_Denmark/CD/papers/013.pdf
View in Google Scholar

[26] "Combined Federated Battle Laboratories Network (CFBLNet)", http://cfbl.nc3a.nato.int
View in Google Scholar

Downloads

Submitted

2023-04-10

Published

2006-09-30

Issue

Section

RESEARCH ARTICLES

How to Cite

[1]
R. Goode, “Planning the introduction of IPv6 in NATO”, JTIT, vol. 25, no. 3, pp. 33–37, Sep. 2006, doi: 10.26636/jtit.2006.3.381.