Statistical Analysis and Modeling of SIP Traffic for Parameter Estimation of Server Hysteretic Overload Control
DOI:
https://doi.org/10.26636/jtit.2013.4.1236Keywords:
Markov Modulated Poisson Process, overload control, SIP server, statistical analysisAbstract
The problem of overload control in Session Initiation Protocol (SIP) signaling networks gives rise to many questions which attract researchers from theoretical and practical point of view. Any mechanism that is claimed to settle this problem down demands estimation of local (control) parameters on which its performance is greatly dependent. In hysteretic mechanism these parameters are those which define hysteretic loops. In order to find appropriate values for parameters one needs adequate model of SIP traffic flow circulating in the network under consideration. In this paper the attempt is made to address this issue. Analysis of SIP traffic collected from telecommunication operator’s network is presented. Traffic profile is built. It is shown that fitting with Markov Modulated Poisson Process with more than 2 phases is accurate. Estimated values of its parameters are given.
Downloads
References
[1] R. Bekker and O. J. Boxma, „An M/G/1 queue with adaptable service speed”, Stoch. Models, vol. 23, no. 3, pp. 373-396, 2007.
View in Google Scholar
[2] A. Chydzinski, „The oscillating queue with finite buffer”, Perform. Eval., vol. 57, no. 3, pp. 341-355, 2004.
View in Google Scholar
[3] B. D. Choi and D. I. Choi, „The queueing system with queue length dependent service times and its application to cell discarding scheme in ATM networks”, IEE Proc. in Commun., vol. 143, pp. 5-11, 1996.
View in Google Scholar
[4] B. Van Houdt, „Analysis of the adaptive MMAP(K)|PH(K)|1 queue: A multi-type queue with adaptive arrivals and general impatience”, Eur. J. Operat. Res., vol. 220, no. 3, pp. 695-704, 2012.
View in Google Scholar
[5] P. Abaev, A. Pechinkin, and R. Razumchik, „On analytical model for optimal SIP server hop-by-hop overload control”, in Proc. 4th Int. Congr. Ultra Modern Telecom. Contr. Syst., Petersburg, Russia, 2012, pp. 303-308.
View in Google Scholar
[6] A. Dudin, „Optimal control for an M[X]/G/1 queue with two operation modes”, Probab. Engin. Inform. Sci., vol. 11, no. 2, pp. 255-265, 1997.
View in Google Scholar
[7] R. Bekker, „Queues with Lévy input and hysteretic control”, Queueing Syst., vol. 63, no. 1, pp. 281-299, 2009.
View in Google Scholar
[8] J. H. Dshalalow, „Queueing systems with state dependent parameters”, in Frontiers in Queueing: Models and Applications in Science and Engineering, J. H. Dshalalow, Ed. Boca Raton, USA: CRC Press, 1997, pp. 61-116.
View in Google Scholar
[9] D. I. Choi, T. S. Kim, and S. Lee, „Analysis of an MMPP|G|1|K queue with queue length dependent arrival rates, and its application to preventive congestion control in telecommunication networks”, Eur. J. Operat. Res., vol. 187, no. 2, pp. 652-659, 2008.
View in Google Scholar
[10] W. Fischer and K. Meier-Hellstern, „The Markov-modulated Poisson process (MMPP) cookbook”, Perform. Eval., vol. 18, no. 2, pp. 149-171, 1993.
View in Google Scholar
[11] S. Shah-Heydari and T. Le-Ngoc, „MMPP models for multimedia traffic”, Telecommun. Syst., vol. 15, no. 3-4, pp. 273-293, 2000.
View in Google Scholar
[12] U. Krieger, Ed., „Achievements on Measurements, IP Traffic Characterization, Classification and Statistical Methods IST-FP6 NoE EuroFGI”, March 2008.
View in Google Scholar
[13] S. Bali and V. Frost, „An algorithm for fitting MMPP to IP traffic traces”, IEEE Commun. Lett., vol. 11, no. 2, pp. 207-209, 2007.
View in Google Scholar
[14] P. Abaev and R. Razumchik, „Queuing Model for SIP Server Hysteretic Overload Control with Bursty Traffic”, in Internet of Things, Smart Spaces, and Next Generation Networking, S. Andreev, S. Balandin, and Y. Koucheryavy, Eds., LNCS, vol. 8121. Heidelberg: Springer, 2013, pp. 383-396.
View in Google Scholar
[15] „SIP: Session Initiation Protocol”, IETF Rec. RFC 3261, 2002.
View in Google Scholar
[16] „IP Multimedia Subsystem (IMS)”, Technical specification, ETSI TS 23.228 V10.5.0 Rel. 10. Stage 2, 2011.
View in Google Scholar
[17] „Session Initiation Protocol (SIP) Basic Call Flow Examples”, IETF Rec. RFC 3665, 2003.
View in Google Scholar
[18] A. Heyde and L. Stewart, „Using the Endace DAG 3.7GF Card with FreeBSD 7.0”, CAIA Tech. Rep. 080507A, Swinburne University of Technology, 2008.
View in Google Scholar
[19] Broadcom NetXtremeII Network Adapter User Guide, 2010.
View in Google Scholar
[20] „Information technology - Open Systems Interconnection - Basic Reference Model: The basic model”, ITU-T Rec. X.200, 1994.
View in Google Scholar
[21] Libpcap Homepage, 2013 [Online]. Available: http://www.tcpdump.org
View in Google Scholar
[22] „Network Time Protocol Version 4: Protocol and Algorithms Specification”, IETF Rec. RFC 5905, 2010.
View in Google Scholar
[23] „The chart is a comparison between NTPv4 and IEEE1588v2 capabilities”, Document of IETF TICTOC, 2008.
View in Google Scholar
[24] Wireshark Homepage, 2013 [Online]. Available: http://www.wireshark.org
View in Google Scholar
[25] Matlab version 7.14, Massachusetts: The MathWorks Inc., 2012.
View in Google Scholar
[26] „Virtual Bridged Local Area Networks”, IEEE Standard 802.1Q, 2005.
View in Google Scholar
[27] Matlab Central [Online]. Available: http://www.mathworks.com/matlabcentral/fileexchange/19148-hurst-parameter-estimate
View in Google Scholar
[28] D. Heyman and D. Lucantoni, „Modeling multiple IP traffic streams with rate limits”, IEEE/ACM Trans. Netw., vol. 11, no. 6, pp. 948-958, 2003.
View in Google Scholar
[29] [Online] http://www.cs.wm.edu/MAPQN/kpc_techniques
View in Google Scholar
[30] A. Arvidsson and P. Karlsson, „On traffic models for TCP/IP”, in Proc. 16th Int. Teletraf. Congr. ITC-16, Edinburgh, UK, 1999, pp. 455-466.
View in Google Scholar
Downloads
Submitted
Published
Issue
Section
License
Copyright (c) 2013 Journal of Telecommunications and Information Technology

This work is licensed under a Creative Commons Attribution 4.0 International License.