Video Streaming Framework
DOI:
https://doi.org/10.26636/jtit.2011.3.1164Keywords:
error resilience and concealment, H.264/AVC, media delivery over IP networks, video codingAbstract
The framework for testing video streaming techniques is presented in this paper. Short review of error resilience and concealments tools available for the H.264/AVC standard is given. The video streaming protocols and the H.264 payload format are also described. The experimental results obtained with the framework are presented in this paper too.
Downloads
References
[1] Information technology - Coding of Audio-Visual Objects - Part 10: Advanced Video Coding, ISO/IEC 14496-10, 2008.
View in Google Scholar
[2] Y. Q. Shi and H. Sun, Image and Video Compression for Multimedia Engineering: Fundamentals, Algorithms, and Standards. CRC Press, 2008.
View in Google Scholar
[3] I. E. Richardson, The H.264 Advanced Video Compression Standard, Wiley, 2010.
View in Google Scholar
[4] A. Kondoz, Visual Media Coding and Transmission, Wiley, 2009.
View in Google Scholar
[5] Information technology - Generic Coding of Moving Pictures and Associated Audio Information: Video, ISO/IEC 13818-2, 2000.
View in Google Scholar
[6] S. Wenger, „H.264/AVC over IP”, IEEE Trans. Circ. Sys. Video Technol., vol. 13, no. 7, pp. 645-656, 2003.
View in Google Scholar
[7] S. K. Im and A. J. Pearmain, „Error resilient video coding with priority data classification using H.264 flexible macroblock ordering”, IET Image Process., vol. 1, no. 2, pp. 197-204, 2007.
View in Google Scholar
[8] B. Katz, S. Greenberg, N. Yarkoni, N. Blaunstien, and R. Giladi, „New error-resilient scheme based on FMO and dynamic redundant slices allocation for wireless video transmission”, IEEE Trans. Broadcast., vol. 53, no. 1, pp. 308-319, 2007.
View in Google Scholar
[9] T. Tillo, M. Grangetto, and G. Olmo, „Redundant slice optimal allocation for H.264 multiple description coding”, IEEE Trans. Circ. Sys. Video Technol., vol. 18, no. 1, pp. 58-70, 2008.
View in Google Scholar
[10] C. Zhu, Y.-K. Wang, M. M. Hannuksela, and H. Li, „Error resilient video coding using redundant pictures”, IEEE Trans. Circ. Sys. Video Technol., vol. 19, no. 1, pp. 9-70, 2009.
View in Google Scholar
[11] O. Harmanci and A. M. Tekalp, „Rate-distortion optimal video transport over IP allowing packets with bit errors”, IEEE Trans. Image Proces., vol. 16, no. 5, pp. 1315-1326, 2007.
View in Google Scholar
[12] I. Radulovic, P. Frossard, Y.-K. Wang, M. M. Hannuksela, and A. Hallapuro, „Multiple description video coding with H.264/AVC redundant pictures”, IEEE Trans. Circ. Sys. Video Technol., vol. 20, no. 1, pp. 144-148, 2010.
View in Google Scholar
[13] K. Sühring, „H.264/AVC JM reference software” [Online]. Available: http://iphome.hhi.de/suehring/tml
View in Google Scholar
[14] A. M. Tourapis, A. Leontaris, K. Sühring, and G. Sullivan, H.264/14496-10 AVC Reference Software Manual, JVT-AE010, 2009.
View in Google Scholar
[15] K.-P. Lim, G. Sullivan, and T. Wiegand, Text Description of Joint Model Reference Encoding Methods and Decoding Concealment Methods, JVT-X101, 2007.
View in Google Scholar
[16] M. Ma, O. C. Au, S.-H. G. Chan, and M.-T. Sun, „Edge-directed error concealment”, IEEE Trans. Circ. Sys. Video Technol., vol. 20, no. 3, pp. 382-395, 2010.
View in Google Scholar
[17] J. Wu, X. Liu, and K.-Y. Yoo, „A temporal error concealment method for H.264/AVC using motion vector recovery”, IEEE Trans. Consumer Electron., vol. 54, no. 4, pp. 1880-1885, 2008.
View in Google Scholar
[18] G.-L. Wu, C.-Y. Chen, T.-H. Wu, and S.-Y. Chien, „Efficient spatial-temporal error concealment algorithm and hardware architecture design for H.264/AVC”, IEEE Trans. Circ. Sys. Video Technol., vol. 20, no. 11, pp. 1409-1422, 2010.
View in Google Scholar
[19] K. Seth, V. Kamakoti, and S. Srinivasan, „Efficient motion vector recovery algorithm for H.264 using B-spline approximation”, IEEE Trans. Broadcast., vol. 56, no. 4, pp. 467-480, 2010.
View in Google Scholar
[20] X. Chen, Y. Y. Chung, C. Bae, X. He, and W.-C. Yeh, „An efficient error concealment algorithm for H.264/AVC using regression modeling-based prediction”, IEEE Trans. Consumer Electron., vol. 56, no. 4, pp. 2694-2701, 2010.
View in Google Scholar
[21] R. Pantos and W. May, HTTP Live Streaming, 2010 [Online]. Available: http://tools.ietf.org/html/draft-pantos-http-live-streaming-04
View in Google Scholar
[22] A. Zambelli, IIS Smooth Streaming Technical Overview, Microsoft Corporation, 2009.
View in Google Scholar
[23] Adobe - HTTP Dynamic Streaming [Online]. Available: http://www.adobe.com/products/httpdynamicstreaming/
View in Google Scholar
[24] Information Technology - MPEG Systems Technologies - Part 6: Dynamic Adaptive Streaming over HTTP (DASH), ISO/IEC FCD 23001-6, ISO/IEC JTC 1/SC 29/WG 11, w11749, 2011.
View in Google Scholar
[25] H. Schulzrinne, S. Casner, R. Frederick, and V. Jacobson, RTP: A Transport Protocol for Real-Time Applications, RFC 3550, 2003.
View in Google Scholar
[26] C. Perkins, RTP Audio and Video for the Internet. Boston: Addison-Wesley, 2006.
View in Google Scholar
[27] M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman, The Secure Real-time Transport Protocol (SRTP), RFC 3711, 2004.
View in Google Scholar
[28] S. Wenger, M. M. Hannuksela, T. Stockhammer, M. Westerlund, D. Singer, RTP Payload Format for H.264 Video, RFC 3984, 2005.
View in Google Scholar
[29] H. Schulzrinne and S. Casner, RTP Profile for Audio and Video Conferences with Minimal Control, RFC 3551, 2003.
View in Google Scholar
[30] M. Handley, V. Jacobson, and C. Perkins, SDP: Session Description Protocol, RFC 4566, 2006.
View in Google Scholar
[31] S. Wenger, Y.-K. Wang, T. Schierl, A. Eleftheriadis, RTP Payload Format for SVC Video [Online]. Available: http://tools.ietf.org/html/draft-ietf-avt-rtp-svc-21
View in Google Scholar
[32] Y.-K. Wang, T. Schierl, RTP Payload Format for MVC Video [Online]. Available: http://tools.ietf.org/html/draft-wang-avt-rtp-mvc-05
View in Google Scholar
[33] Linux Media Infrastructure API [Online]. Available: http://www.linuxtv.org/downloads/v4l-dvb-apis
View in Google Scholar
[34] Qt - A cross-platform application and UI framework [Online]. Available: http://qt.nokia.com/products
View in Google Scholar
[35] Qwt - Qt Widgets for Technical Applications [Online]. Available: http://qwt.sourceforge.net
View in Google Scholar
[36] Jori’s page - CS/Jrtplib [Online]. Available: http://research.edm.uhasselt.be/~jori/page/index.php?n=CS.Jrtplib
View in Google Scholar
[37] FFmpeg [Online]. Available: http://www.ffmpeg.org
View in Google Scholar
[38] VideoLAN - x264, the best H.264/AVC Encoder [Online]. Available: http://www.videolan.org/developers/x264.html
View in Google Scholar
Downloads
Submitted
Published
Issue
Section
License
Copyright (c) 2023 Journal of Telecommunications and Information Technology

This work is licensed under a Creative Commons Attribution 4.0 International License.