Communication Platform for Evaluation of Transmitted Speech Quality
DOI:
https://doi.org/10.26636/jtit.2011.3.1163Keywords:
acoustic echo cancelation, doubletalk detection, echo-hidingAbstract
A voice communication system designed and implemented is described. The purpose of the presented platform was to enable a series of experiments related to the quality assessment of algorithms used in the coding and transmitting of speech. The system is equipped with tools for recording signals at each stage of processing, making it possible to subject them to subjective assessments by listening tests or, objective evaluation employing PESQ or PSQM algorithms. The functionality for the simulation of distortions typical for voice communication over the Internet was implemented, making it possible to obtain reproducible, quantifiable results. An application of the presented platform for evaluation of acoustic echo canceler algorithm based on watermarking techniques, which was developed earlier is presented as an example of an effective deployment of the described technology.
Downloads
References
[1] G. Szwoch, A. Czyżewski, and A. Ciarkowski, „A double-talk detector using watermarking”, J. Audio Eng. Soc., vol. 57, pp. 916-926, 2009.
View in Google Scholar
[2] A. Czyżewski and G. Szwoch, „Method and Apparatus for Acoustic Echo Cancellation in VoIP Terminal”. International Patent Application No. PCT/PL2008/000048, 2008.
View in Google Scholar
[3] H. Schulzrinne et al., „RTP: A Transport Protocol for Real-Time Applications”, RFC 3550, IETF, 2003.
View in Google Scholar
[4] D. L. Duttweiler, „A twelve-channel digital echo canceler”, IEEE Trans. Commun., vol. 26, pp. 647-653, 1978.
View in Google Scholar
[5] S. M. Kuo, B. H. Lee, and W. Tian, „Adaptive echo cancelation”, in Real-Time Digital Signal Processing: Implementations and Applications (2nd ed), S. M. Kuo et al., Eds. Chichester: Wiley, 2006, pp. 443-473.
View in Google Scholar
[6] J.-M. Valin, „The Speex Codec Manual”, May 9, 2011, http://speex.org/docs/manual/speex-manual/
View in Google Scholar
[7] J. Benesty, D. R. Morgan, and J. H. Cho, „A new class of doubletalk detectors based on cross-correlation”, IEEE Trans. Speech Audio Process., vol. 8, pp. 168-172, 2000.
View in Google Scholar
[8] „Pulse code modulation (PCM) of voice frequencies”, ITU-T Recommendation G.711 (11/88), Int. Telecomm. Union, Geneva, Switzerland, 1988.
View in Google Scholar
[9] „7 kHz audio-coding within 64 kbit/s”, ITU-T Recommendation G.722 (11/88), Int. Telecomm. Union, Geneva, Switzerland, 1988.
View in Google Scholar
[10] „Dual rate speech coder for multimedia communications transmitting at 5.3 and 6.3 kbit/s”, ITU-T Recommendation G.723.1 (05/06), Int. Telecomm. Union, Geneva, Switzerland, 2006.
View in Google Scholar
[11] „40, 32, 24, 16 kbit/s Adaptive Differential Pulse Code Modulation (ADPCM)”, ITU-T Recommendation G.726 (12/90), Int. Telecomm. Union, Geneva, Switzerland, 1990.
View in Google Scholar
[12] „Coding of speech at 8 kbit/s using conjugate-structure algebraic-code-excited linear prediction (CS-ACELP)”, ITU-T Recommendation G.729 (01/07), Int. Telecomm. Union, Geneva, Switzerland, 2007.
View in Google Scholar
[13] H. Schulzrinne and S. Casner, „RTP Profile for Audio and Video Conferences with Minimal Control”, RFC 3551, IETF, 2003.
View in Google Scholar
[14] „GSM Full Rate Speech Transcoding”. Europ. Telecomm. Standards Inst. (ETSI), Sophia Antipolis, France, Recommendation GSM 06.10, 1992.
View in Google Scholar
[15] S. Andersen et al., „Internet Low Bit Rate Codec (iLBC)”, RFC 3951, IETF, 2004.
View in Google Scholar
[16] „A High Quality Low Complexity Algorithm for Packet Loss Concealment with G.711”, ITU-T Recommendation G.711 Appendix I (09/99), Int. Telecomm. Union, Geneva, Switzerland, 1999.
View in Google Scholar
[17] J. H. Cho, D. R. Morgan, and J. Benesty, „An objective technique for evaluating doubletalk detectors in acoustic echo cancelers”, IEEE Trans. Speech Audio Process., vol. 7, pp. 718-724, 1999.
View in Google Scholar
[18] S. L. Gay and J. Benesty, „An introduction to acoustic echo and noise control”, in Acoustic Signal Processing for Telecommunication, S. L. Gay and J. Benesty, Eds. Norwell: Kluwer, 2000, pp. 1-18.
View in Google Scholar
[19] J. Benesty et al., Advances in Network and Acoustic Echo Cancellation. Berlin: Springer, 2001.
View in Google Scholar
[20] M. Baugher et al., „The Secure Real-time Transport Protocol (SRTP)”, RFC 3711, IETF, 2004.
View in Google Scholar
Downloads
Submitted
Published
Issue
Section
License
Copyright (c) 2023 Journal of Telecommunications and Information Technology

This work is licensed under a Creative Commons Attribution 4.0 International License.